Audio settings and loading song catalog

November 3, 2012, 11:32P


Hi Admin,

I need your help with setting up the audio for Karaoke7. I downloaded the program Karaoke7 and installed it successfully in my Atom HTPC running windows 8. However, I could only hear some background music which sounded like it was so stretched out. I suspected it could be audio driver. I then downloaded the ASIO4All driver and installed in my htpc. I selected the ASIO4All driver under the setting --> audio device-->...then exit the program --> relaunch the program, but it did not solve the problem. I even did system recovery the entire my htpc to the date before I installed karaoke7...then reintalled everything, it still did not work for me. I do not know what caused the problem and I need your help.

In addition, the program Karaoke7 program crashed when I launched song catalog!

November 4, 2012, 2:59A



I experienced issue with audio "stretched out" as described in previous post. It happen only certain songs, not sure which format yet, maybe on MKV.

I played the song with issue with different player (VLC), on the same machine, and it played fine. Also played same song on different machine, which running Karaoke4vipAtom, and it played fine without issue. So it appeared to be issue with Karaoke7.


November 4, 2012, 3:18A


resample the audio to 48khz, songs you hear strech out may be output 44.1khz.

go to ffdshow config check resample ,select 48khz

the song catalog may have problem on some machine, I dont know what cause yet.

you can use the karaoke7A.exe for slow machine. use karaoke7client fot the song catalog

November 5, 2012, 2:00A


I reinstalled the K-lite codec pack and reconfigured resample to 48Khz in ffdshow audio decoder configuration, then I restarted my Atom PC --> reset the audio device settings --> relaunched the program. However, it did not resolve the "stretch out" audio problem. Any other suggestions? Thanks.

Where I can download the karaoke7A.exe?

November 5, 2012, 2:24A


did you check ffdshow output 2channels (stereo) ?

made shure ffdshow output 2channels-48khz

November 5, 2012, 2:36A


How can I get to ffdshow output 2 channels?

I saw the "Output" section in ffdshow audio decoder configuration, but I do not see any checkbox for ffdshow output 2 channels?

Also, I just got an error window showing that "can't add audio decoder to path."

Last edited by rongwam, November 5, 2012, 2:44A

November 5, 2012, 4:07A


in the mixer check box, you can select speaker configuration

try enable all audio codec in ffdshow like uncompressed set to all

November 5, 2012, 1:17P


Hi Admin,

I checked the mixer checkbox --> select speaker configuration 2/0/0 stereo, but it does not appear to resolve the "stretched out" audio problem.

Also downloaded karaoke7a.exe, and it still has the same problem as that of regular karaoke7

Any suggestions? Thanks.

November 5, 2012, 8:18P


can you PM me the teamvier id and password ?

just leave your computer on about 24 hours, I will come to take a look when I have time

November 6, 2012, 11:55A


Hi Admin,

Can you tell me how I can get the teamviewer id and password? Thanks

November 7, 2012, 1:31A


rongwam said:

Hi Admin,

Can you tell me how I can get the teamviewer id and password? Thanks

Download -> install/run

November 14, 2012, 6:20P


It worked. I uninstalled previous karaoke7 version, and installed karaoke7a, resetted the audio settings to WASAPI and playback device with HDMI digital audio.

Thanks, admin!

November 15, 2012, 12:14A


Hi Rongwam,

Where is 7a ?


November 15, 2012, 1:24A


Anyone !!!

November 16, 2012, 5:05A


Last edited by rongwam, November 16, 2012, 5:06A

November 18, 2012, 4:41P


Thanks Rongwam

karaoke4pro Forums - ©2018, Karaoke For Pro, LLC